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Documentation describes the modifications for midas GTS V300 R4.  

I) Improvements 

- Hoek-Brown Model 

- Modified Mohr-Coulomb 

- Cam Clay and Modified Cam Clay Models 

- Tabular Input for Material Properties 

- User Defined Phreatic Surfaces 

- Input Data ASCII File 

- Non-symmetric Multi-Frontal Direct Solver 

- File Exchange with midas Civil and midas Gen 

- Quadrilateral and Q-morph Mesher 

- Align Edge Seed Near Inner Loop 

- Mesh Clean-Up 

- Post Remesh 

- Align edge seed near inner loop 

- Mesh Clean-Up 

- Auto Mesh Solid : Advanced Option : Post Remesh 

- Mesh Preference :  Seeding Options 

- Measuring Element Properties 

- New Extruding Feature 

- Creating a single node using Center of Mass Summation 

- Create a surface using solid or 2D models. 

 
II) Bug Fixes 

- Analysis 

- Pre/Post Processing 

 

III) Known Issues 

 

 



  

  

GGTTSS  VV330000  RReelleeaassee  NNootteess  

  
IImmpprroovveemmeennttss  

  
  

  

  

www.midasuser.com   Revision Date:  September 21, 2009  

Hoek-Brown Model   

In GTS V251, the return algorithm by Euler forward method uses an internal tolerance of 1.0 e-6.  In GTS 
V300, instead of using the Euler forward method, a Cutting plane method has been implemented.  This 
method is similar to the Euler Backward method, which uses an internal tolerance of 1.0e-3 and a routine 
that improves convergence by internal discretization of strength.  In previous implementation, an 
Erroneous formula that was in the first order gradient equation has been corrected. 

 

 

Modified Mohr Coulomb 

a) In GTS V251, the Modified Mohr Coulomb (MMC) model has been updated such that the behavior 
at low cohesion values is more robust in this version. Further, in case initial stresses are defined 
for the MMC model elements, the size of the initial yield-surface is now automatically calibrated to 
the initial stresses in the respective integration-points, such that larger load-increments can be 
applied in initial loading of the elements. 

 

b) In the Modified-Mohr Coulomb material model, if the user inputs Unloading/Reloading Stiffness 
(Eurref) equal to or less than the primary loading stiffness (Eoedref), a warning message in the Output 
window is displayed suggesting the value should be larger.  
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Cam Clay & Modified Cam Clay midas GTS can now represent undrained and drained 
behavior of soft clays and for-saturated and unsaturated 
conditions. 
 

  

 

1) Cam Clay model:  

Pore-Water Pressure (Pa) vs. Axial 
Strain for drained conditions 

2)   Modified Cam Clay model:  

von Mises (Pa) vs. mean effective stress 

(Pa) 
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Tabular input for Material Properties An additional feature has been added in GTS V300 
that enables material property input through table 
format.  The table is fully compatible with MS-Excel 
and users can edit the table for changing material 
properties. 

 

 

User Defined Phreatic Surface  A new feature that allows users to define phreatic 
surfaces in 2D by means of a geometry function.  
This can be done in the construction stage 
definition menu or separately through Model > 
Water level menu.  The user can also select an 
existing geometry curve to be used as phreatic 
surface.  In 3D, a constant water level can only 
be defined for the time being.  However, it can be 
changed per construction stages. 
 

Automatic generation of Water Level 

function 

Contour of pore pressure post analysis 
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Input Data ASCII File User input data can be automatically saved as a 
*.txt format for reference.  The file is generated at 
the end of the analysis and is referred to as 
*_InputData.txt.   

 

 
 
Non-symmetric Multi-Frontal Direct Solver 
 
A standard Iterative solver is commonly used to handle linear systems with large sparse non-
associated material models.  However, it is cumbersome to predict whether the solver will 
converge or if it is capable of delivering accurate results due to the solver‟s reliance on tolerance 
settings.  Moreover, iterative solvers are generally slow at converging or only converge for some 
cases.  In order to provide better functionality, midas GTS has an enhanced Multi-Frontal Direct 
solver capable of handling not only associated but non-associated material models.  The 
advantage in using a Multi-Frontal solver for non-associated material models can save users 
time while providing accurate results.  
 
When the parameters, internal frictional angle and dilatancy angle are not equal, the Multi-
Frontal Direct solver automatically performs analysis for a non-symmetric system.  In short, the 
added enhancement in midas GTS provides a Multi-Frontal Direct solver and iterative operation 
for associated and non-associated material models. 
 

Output *.txt file containing User Input Data 

Output of User Input Data 
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File Exchange with midas 
Civil and midas Gen 

Saved Frame data files from midas Civil and 
midas Gen can be converted in GTS from a 
frame to solid (Geometry> Frame -> Solid).  
This function converts the data into a 
geometrical or mesh interpretation.  The frame 
to solid function contains an interpolation 
scheme providing users with smooth and 
straight functions.  In addition, a Generate 
Mesh function contains three options for solid to 
mesh generation: Hexa/Penta, Tetra, and 
Element size. 
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Warning message regarding self-

weight activation  

In GTS V251, all analysis types can be 

analyzed regardless of the self-weight 

being activated or not.  If the user forgot 

to activate self-weight, it was 

cumbersome for the user to re-run the 

analysis.  This has been improved in GTS 

V300 so that a warning message notifies 

users about the status of the self-weight 

load after executing the Analysis > Solve 

command.    

 

 

Linear Static Analysis for initial Construction Stage 

In GTS V300, initial construction stage has been modified to only perform a linear static 

analysis to improve convergence. 

Opening corrupted GTS files   

In GTS V300, saved model files containing entangled node connectivity can now be opened 

without importing the corrupted elements; and output the Element IDs and nodal information 

in the Output Window.   

Truss/Embedded Truss  

GTS V300 provides the following truss types when defining prestress: 

1. Tension Only/Hook                                                     2.   Compression Only/Gap 
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Q-Morph Mesher 

 

Quad-morphing is a technique that 

maintains all of the desirable features from 

paving algorithm and addresses some of 

its weakness. Quad-morphing uses an 

indirect method for generating 

quadrilaterals by taking advantage of local 

topology information from an existing 

triangle mesh. Beginning with an initial 

triangulation, triangles are systematically 

transformed and combined.  An advancing 

front method is used to determine the 

order of transformations.   An all-

quadrilateral mesh containing elements, 

aligned with the area boundaries with 

fewer irregular internal nodes, can be 

generated. [1] 

Advantages 

1) Boundary Sensitive: Able to 
generate boundary sensitive rows 
of elements with few irregular 
nodes.  Mesh contours closely 
follow the contours of 
the boundary Mesh. 

2) Orientation Insensitive: The 
resulting mesh topology is 
unaffected by geometry rotation or 
translation.  

3) Few Irregular nodes: Able to mesh 
with   few irregular nodes near the 
boundary where the element 
shape 

 

 

. 

 

Disadvantage 

1) After generating the initial triangle 
mesh, the quadrilateral 
transformation processing time is 
longer, due to 3D surface mesh. 
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Align edge seed near inner loop Improves the mesh quality, if an inner loop (hole) 

exists near the outer loop (boundary) of the face, 

edge seeding of the inner loop will align the edge 

seed near the inner loop with the outer loop 

edge.  

 

 

 

 

(a)             (b) 
Align edge seed near inner loop (a) Unchecked (b) 

Checked. 
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Mesh Clean-Up 

 

Mesh->Auto Mesh Face ->Advanced Option-

>Mesh Clean-Up:  Improves the quality of 

quadrilateral finite element meshes.  Cleans all 

unused data from all selected mesh objects by 

improving node connectivity, boundary and 

flange patterns, quad shape, and to some 

extent, quad size.  
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Post Remesh 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

Menu : Mesh > 2D Mesh > Auto Mesh Face, 
Mesh > 3D Mesh> Auto Mesh Solid : 
Advanced Option 
 
Post Remesh can be set before automeshing.  
When selected, it improves poor quality mesh 
from auto meshing.  The existing mesh is 
deleted when the surface is remeshed  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 



  

  

GGTTSS  VV330000  RReelleeaassee  NNootteess  

  
IImmpprroovveemmeennttss  

  
  

  

  

www.midasuser.com   Revision Date:  September 21, 2009  

 

    
 
 
   
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Mesh > Mesh Preference: Seeding Options 

 

Even Number of 
Seeds: 

Creates an extra node if 
elements contain odd 
number of nodes.  Helps 
users to create quadrilaterial 
elements. 

 
Regard Mesh 
Size as 
Maximum: 

 
Forces the number of nodes 
on an element to create an 
even number of nodes. 

 
Display Number 
of Seeds: 

 
Displays total number of 
seeds per edge. 
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Model > Element > Measure 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Description:  This function allows users to measure element properties. 
  
        Dimension         Property 
 

1D: Length 
2D: Volume, Area, Mass, Weight 
3D: Volume, Mass, Weight 
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Mesh > Protrude Mesh > Extrude  
 

Description: Allows users to select an edge and extrude in the selected direction while 
controling the mesh length, offset/times, divisions. 
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Model > Node > Create  
 

Description: Creates a node using the center of mass summation function. 
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Geometry > Extract  
 

Description: Allows the users to create surface only from a solid or 2D models. 
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1. Slope stability analysis with higher-order 

triangular shaped elements 

Analysis> Analysis Case > Slope Stability (SAM)… 

In GTS V251, an error occurred when users performed slope stability analysis using SAM method 

on higher-order triangular shaped elements.  This has been resolved in GTS V300. 

2. Deactivating prescribed displacement 

load in construction stage analysis  

Model > Load > Prescribed Displacement… 

In GTS V251, the prescribed displacement remained active despite having them deactivated in the 

construction stage definition.  This has been resolved in GTS V300. 

3. Incremental variation of Modulus of 

Elasticity and Cohesion with Depth 

Model > Property > Material… 

In GTS V251, when the reference height is defined anywhere in the model except ground surface for 

model types Linear, Drucker-Prager, and Mohr Coulomb, the material models‟ incremental 

parameters, such as modulus of elasticity and cohesion incorrectly applied above the reference line.  

This has been resolved in GTS V300. 

4. Seepage Analysis Model > Construction Stage > Define Construction 

Stage… 

In GTS V251, when performing a combined Construction Stage and Seepage (steady 

state/transient) analysis, the seepage parameters, modified by Change Element Attributes, were not 

reflected in the analysis results.  This has been resolved in GTS V300. 

5. Stress-Seepage Semi-Coupled Analysis Analysis > Analysis Case > Construction stage… 

In GTS V251, for vertical infiltration and horizontal infiltration scenarios, the results from stress-

seepage semi-coupled analysis were incorrect.  This analysis calculated the effective stresses using 

pore-pressure by considering the hydraulic gradient.  This has been resolved in GTS V300 by 

considering the variation of pore pressure from the Stress-Seepage Couple Analysis.  

6. Stress initialization in construction-

staged analysis 

Analysis > Analysis Case > Construction Stage… 

In GTS V251, at initial construction stage the internal solver failed to reset the initial strains to zero. 

This has been resolved in GTS V300.  Both the displacement and strain values are set to zero in 

initial construction stage.   

7. Linear Static Analysis Model > Elements > Create Interfaces… 

In GTS V251, the solver terminated when using 16 node plane interface elements. .This has been 

resolved in GTS V300.   
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8. Drucker-Prager Model Model > Property > Material… 

Analysis> General Analysis Control… 

In GTS V251, when performing nonlinear analysis with the constant stiffness method, the solver did 

not recognize Drucker-Prager model‟s input parameters such as increment of modulus of elasticity 

and cohesion.  This has been resolved in GTS V300. 

9. Abnormal termination of Dynamic 

Analysis  

Analysis > Analysis Case  > Time History (Linear) 

GTS V300 displays an error message appeared when performing a 2D or 3D dynamic analysis with 

pile type elements and/or interfaces.  

10. Slope stability analysis Analysis > Analysis Case > Slope Stability…    

In GTS V251, when the slope is critically unstable that it can fail by self-weight, the program 

terminated. This has been resolved in GTS V300. 

11. Transversely Isotropic & Jointed Rock 

Models 

Model > Property > Material… 

In GTS V251, when the option “Shear modulus” is not selected for Transversely Isotropic and 

Jointed Rock models, the shear modulus was incorrectly calculated.  This has been resolved in GTS 

V300. 

12. Strain results in Plate Output Coordinate 
System 

Property >Property : Output Coordinate System 

Post-Works > Plate Strains 

In GTS V251, strain results for plate elements did not transfer properly to the Plate Output Coordinate 

System. This error did not occur for the force/stress results. This has been resolved in GTS V300. 

 

13. 2D Geogrid Element Application Model > Property > Property > Plane Type: 

Geogrid (2D)… 

In GTS V251, the solver incorrectly calculated the stresses of 2D Geogrid elements.  This has been 

resolved in GTS V300. 

14. Lower/higher-order interface elements Model > Elements > Create Interface… 

In GTS V251, if one file contains two models with different order of interface elements, the program 

terminated when selecting results of the interface.  This has been resolved in GTS V300. 
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15. Consolidation analysis Analysis > Analysis Case > Consolidation… 

In GTS V251, the higher order plate and plane-strain elements modeled in the consolidation analysis 

type did not activate into the solver-causing it to terminate.  This has been resolved in GTS V300. 

16. 3D Geogrid element  Analysis > Analysis Case > Construction stage… 

An error occurred when 3D Geogrid elements were activated in the Construction Stage.  The solver 

did not correctly calculate the stresses in between the linear and non-linear transition.  This has been 

resolved in GTS V300. 

 

17. Mohr-Coulomb Ko input parameter Model > Property > Attribute… 

When enabling the Tensile strength for a Mohr Coulomb model type, the value 1.0 was assigned to 

any user-defined Ko input parameter. This has been resolved in GTS V300. 

18. Seepage stress analysis  Analysis > Analysis Case > Construction stage… 

Computation of Seepage force did not consider water density.  This has been resolved in GTS V300. 

19. Surface Spring Model > Property > Property… 

GTS V300 automatically constrains the rotational degrees of freedom.  This has been resolved so that 

constraints can be only defined by the user. 

20. Nonlinear analysis using high order  
plate and solid elements 
 

Analysis > Solve… 

High order tetra elements used with higher order plate elements caused the solver to occasionally  

crash in nonlinear analysis.  This has been resolved in GTS V300R3. 
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2. Matrix Spring Model > Property > Property…  

In GTS V251, when the Matrix Spring is considered in the Construction Stage, all spring coefficients 

returned the value zero.  This has been resolved in GTS V300. 

3. Display of Label Arrows Model > Load > Pressure Load…  

In GTS V251, Label Arrows‟ direction for pressure loads displayed negative loading values 

incorrectly. The routine function has been resolved in GTS V300 so that the Label Arrows are 

displayed correctly. 

4. Importing Pile Attributes  Model > Property > Attribute… 

In GTS V251 an error occurred when importing pile element attributes into a model.  This has been 

resolved in GTS V300 so that users are able to import pile element attributes. 

5. Display Material/Property of Interface 

Elements  

Model > Display Material/Property… 

In GTS V251, differentiating interface elements with different material properties using Display 

Material/Property function did not work.  This has been resolved in GTS V300 so that interface 

elements can be easily differentiated from a list of other properties. 

6. Input of Water level pre/post Model > Construction Stage > Define Construction 

Stage… 

In GTS V251, the units for water level value defined in „Define Construction Stage‟ dialog box did not 

update automatically.  This has been resolved in GTS V300 so that the units update and are 

reflected in the analysis. 

7. Table format regarding input of Prestress  Model > Load > Prestress… 

In GTS V251, the prestress values could be modified from work tree > table; however, any changes 

made in the table did not update and reflect in the analysis.  This has been resolved in GTS V300. 

8. Change element property for 1D interface Model > Element > Change Parameter… 

In GTS V251 changing the Lower-order 1D interface elements to higher-order was not possible and 

prompted an error message.  This has been resolved in GTS V300. 

 

 

 

1. Updating Units of Pile Element Model > Property > Property… 

In GTS V251, Pile elements’ units pertaining to Reference Depth and Slope of Friction-Rel Disp. 

curve did not update automatically.  This has been resolved in GTS V300 so that the units for 

Reference depth and Slope of Friction-Rel. Disp. curve updates automatically. 
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9. Modified Mesh Control Mesh > Size Control > Display Mesh Seed 

Mesh > Delete Control Data 

In GTS V251, errors resulted for the following three cases: editing of the edge seeds, displaying 

seeds for sections containing mesh seeding, and deleting most of the assigned mesh seeds using 

“Delete Control Data…”  This has been resolved in GTS V300 so that any modification in the pre-

processing Mesh Control is allowed. 

10. Generating Elastic link using Surface 

Spring 

Model > Element > Create Surface Spring…  

GTS V251 does not generate surface spring (elastic link types) at the element edges for higher-

order elements.  This has been resolved in GTS V300. 

11. Results of deactivated interface elements  Analysis >Analysis Case >Construction Stage 

In GTS V251, when deactivating interface elements during the construction stage, the deactivated 

interface elements remained active in the results.  This has been resolved in GTS V 300. 

12. Saving Parametric Study Data Analysis > Parametric Study... 

In GTS V251, an error occurred when opening saved parametric study files.  This has been resolved 

in GTS V300. 

13. Extract Results  Result > Extract Result… 

In GTS V251, when calling the Extract Result function for 1D beam elements, the table results 

displays the nodal coordinates in the z-direction incorrectly.  This has been resolved in GTS V300 so 

that the table‟s algorithm properly outputs the extracted positions. 

14. Report Generation output for 

plate/embedded truss elements 

Result > Result Summary >Report Generation… 

In GTS V251, the report generation function failed to include plate/embedded truss elements results.  

This has been resolved in GTS V300. 

15. Result component combination Result > Results Component Combinations…  

In GTS V251, when defining a model with linear elements, users can use the function “Result 

component combination” to obtain a contour as an output for post-processing.  However, using 

higher-order elements outputted the results as zero.  This has been resolved in GTS V300. 

16. von Mises stress Post Data > Solid Stresses : von Mises  

In GTS V251, von Mises stresses of solid elements subjected to identical uniform pressure 

distribution on two orthogonal surfaces were very close to zero but not exactly zero due to a 

rounding error.  This has been resolved in GTS V300. 
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17. Defining von Mises properties for Beam 

Elements 

Model > Property >Attribute  

When defining the material properties for Beam elements, none of the von Mises parameters were 

correctly transferred to the solver.  This has been resolved in GTS V300. 

18. Plate element’s rotational results Model > Property >Attribute  

In the post works tree window, the rotational degrees of freedom were not considered.  This affected 

all the results for bending components.  This has been resolved in GTS V300R3. 

19. Local Direction Force Sum Result > Local Direction Force Sum 

The Local Direction Force sum function was unable to generate results for a solid or plate element 

types.  This has been resolved in GTS V300. 

20. Nodal Prescribed displacement results Result > Displacement 

Using node local axis coordinates, the assignment of prescribed nodal displacement only displayed 

displacement at 50%.  This has been resolved in GTS V300. 

21. Elastic Link Force Results Result > Result Tables > Elastic Link Force 

Incorrect information about the Elastic Link Forces was displayed for some elements.  This has been 

resolved in GTS V300. 

22. Principal Stress Nomenclature Post-Works  

The nomenclature for maximum and minimum principal stresses has been changed.  Maximum and 

minimum principal stresses are now defined as P3 (V) and P1 (V), respectively. 

23. Quadrilateral interface elements Post-Works 

The results of quadrilateral interface element (low order and high order) did not display any contour 

plots.  This has been resolved in GTS V300. 

 

 

 
 
 
 
 
 
 
 
 
 
 



  

  

GGTTSS  VV330000  RReelleeaassee  NNootteess  

  
KKnnoowwnn  IIssssuueess  

  

www.midasuser.com   Revision Date:  September 21, 2009  

 „Model>Load>Pressure Load>Edge pressure‟ is not applicable in 3D analysis. Loads along 
edges of solids should be specified using the function „Model>Load>Force>Curve‟. 

 

 Note that no strain results are available in linear static analysis. Please use non-linear 
analysis with linear elastic material if strain results are required. 

 

 Note that three-noded beam or truss elements are not available. When using 2D or 3D 
quadratic elements, first create 2-noded beams with the same element size as the adjacent 
quadratic elements. Then restore full nodal compatibility using „Model>Element>Divide 1D 
Element‟ using Number of Divisions=2 and the Merge Node option selected. 

 

 The rigid link property dialogue (in Spring/Interface tab) allows specifying rigid connections 
in translations (DX, DY, DZ) and in rotation (RX, RY, RZ). When rigid links connect two 
mesh sets with translational degrees of freedom (DOF) only, e.g. connecting plain strain 
elements or solid elements, only translational DOF should be activated in the rigid link 
property dialogue. If rotational DOF are specified in the rigid link definition, it will result in the 
analysis aborting. Similarly, for 2D analysis, only DOF in the analysis plane should be 
activated in the rigid link dialogue. 


