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Enhancements

(1) Dynamic Report Generation

(2) Revit Structure 2010 Interface

and much more…

 Pre/Post Processing

 Analysis 

 Design

(1) Analysis Stop Option in the Pushover Analysis

(2) Improved Pushover Analysis Results

and much more…

(1) Deflection Check considering Cracked Section

(2) Limiting Rebar Ratio

(3) Limiting Minimum Section Size

and much more…
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(1) Dynamic Report Generation

(2) Revit Structure 2010 Interface

(3) Pressure Type of Beam Loads

(4) Improved Eccentricity Option in the Element Beam Load 
and Line Beam Load

(5) Improved India Standard Section DB

(6) Changes in the Default Values of Stiffness Scale Factor in 
the Composite Section for Construction Stage

(7) Addition of Dimension Import

 List of Detailed Enhancements in Pre & Post Processing
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• Word format reports can automatically be generated for selected input & output data 
(figures, tables, graphs, and text).

• Using “Dynamic Report Regenerator” function, changes of a model file are automatically 
updated in the report.

• User defined report format can be used and saved.

1. Dynamic Report Generation

Tools > Dynamic Report Generator

1

Tools > Dynamic Report Image

Tools > Dynamic Report Auto Generation

Drag & Drop
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Step 1. Open a midas Gen model file. 

Step 2. Register contents (images, tables, text summary…) to be entered in the report. 

Registered contents are displayed in the Report Tree.

Step 3. Open a new report. 

Step 4. Insert the contents by Drag & Drop from the Report Tree.

Step 5. Modify the report file in the Report Editor and save it in MS word format.

Procedure for Dynamic Report Generation

Register the desired data

Insert contents by Drag & Drop

Open a new report Report Tree
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Procedure for Auto Regeneration

If there are any changes in the model file, we can automatically update the pre-generated 
report. If the user manually entered additional text or images into the report, those data will 
remain. 

Step 1. Select Tools > Dynamic Report Image from the Main Menu, or click icon to open the 
Auto Regeneration List dialog box. 

Step 2. All the entered data will be displayed in each tab by data formats. Select the desired 
data to be updated. 

Step 3. Click [Regenerate] button.

Open the pre-generated report

Select the desired contents to be updated 
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Using Midas Link for Revit Structure, direct data transfer between midas Gen and Revit

Structure 2010 is available for Building Information Modeling (BIM) workflow. Midas Link

for Revit Structure enables us to directly transfer a Revit model data to midas Gen, and

delivery back to the Revit model file. It is provided as an Add-In module in Revit Structure

and midas Gen text file (*.mgt) is used for the roundtrip.

Midas Link for Revit Structure supports the following workflows:

(1) Send the Revit Structure analytical model to midas Gen.

(2) Import the MGT file of the Revit model in midas Gen.

(3) Export the midas model file to the MGT file.

(4) Update the Revit Structure model from midas Gen

2. Revit Structure 2010 Interface
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Getting Started

The following exercise leads you through a sample scenario providing detailed instructions 
for each step in the process.

Step 2: Send Model to midas Gen

1. Click Tools menu > External Tools > Send Model to midas Gen
2. 2. Click OK to send the project using the default.

The following table shows the Revit components that are sent to midas Gen.
It also shows the corresponding MIDAS commands used in the MGT file.

Step 1: Prepare a Model

1. Using the structural template, build a simple structure that has
4 beams, 4 columns, 4 boundary conditions, 1 point load, and 1
line load with host, as shown.

2. Create a load combination; create a load combination usage
called MIDAS_STEEL; set the load combination to this usage.

Revit Structure midas Gen MGT

Level STORY

Grid GRIDLINE

Wall ELEMENT (WALL), NODE

Frame Element (beam, brace) ELEMENT (BEAM) - multiple if split, NODE, FRAME-RLS

Column ELEMENT (BEAM) - multiple if split, NODE, FRAME-RLS

Footing CONSTRAINT – rigid

Boundary Condition (Point) CONSTRAINT, SPRING

Load Case STLDCASE

Load Combination
(with usage name beginning with MIDAS_)

LOADCOMB

Point Load (on frame element or column ends) CONLOAD

Point Load (on frame element or column interior) BEAMLOAD (CONLOAD)

Line Load (on single frame element or column) LINELOAD, PRESSURE

Area Load (fully enclosed by frame elements or columns) FLOORLOAD

Rigid Link RIGIDLINK

Material MATERIAL

Section SECTION

Wall Thickness THICKNESS

3. Check for inconsistency by clicking Tools menu > Analytical Model > Analytical / Physical
Model Consistency Checks. Make any adjustments if necessary.
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Step 3: Analyze and Revise Model in midas Gen

1. Start a new project in midas Gen, and import the MGT file of the Revit model. Note any
warnings and errors in the message window.

2. Import the MGT file again, it should import without error and display the structure.

3. Perform a structural analysis in order to be sure that the model is complete.

4. Add a horizontal brace to the model in section 1.

5. Reduce the size of the columns from W10x49 (section 8) to W10x33 (section 9).

6. Export the model using the same name as the imported MGT file.

Step 4: Update Model from midas Gen

1. In Revit Structure, click Tools menu > External Tools > Update Model from midas Gen

2. Verify that the paths in the dialog point to the right files, and click Update. The
summary should report 1 added element and 4 section changes, and the structure
should now look like the following illustration.
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Send Model to midas Gen

1.In order to send the Revit Structure analytical model to midas Gen, click Add Ins >

External Tools > Send Model to MIDAS/Gen.

2.Click the first Browse button to select a path for the Revit model file. The paths for the

MIDAS model and the log file will default to the same name. If necessary, modify these

paths by clicking the corresponding Browse buttons.

(2)

(3)

(4)

3.Under the midas Gen Information group, select the units for length and force to be used

in midas Gen.

(5)

(6)

(7)
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4. Section DB File

SectionMap.smap file is a section transfer list file from Revit Structure to midas Gen. The
user can directly add or modify SectionMap.smap file to specify section shapes and size
imported in midas Gen.
Section transfer data are written in the following formats:

Revit Family Name: Family Name used in Revit Structure
Revit Type Name: Element type name used in Revit Structure
Gen Code Name: Section DB code which will be used in midas Gen
Section Shape: Section shape name which will be used in midas Gen (ex. H, L, C, T, P…)

Gen Section Name: Section name in the specified section DB code

Apply the current setting to SDB file

If an unidentified section exists in a Revit model, the following dialog box is displayed to
specify the section shape and size imported in midas Gen. When “Code” is selected in
the following dialog box, only “SB (Solid Box)” can be selected for Shape.
If Apply the current setting to SDB file option is checked on, the setting will be saved in
ectionMap.smap so that the user do not need to specify them again.
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6. Select a default material DB. If the material data is not specified in the Material DB
File, default material will be applied in midas Gen.

7. Click Send to start writing the MIDAS model.
When the writing is complete, a summary will be presented in a dialog. If the

summary indicates issues, further details are available by clicking View Log File.

5. Material DB File
MaterialMap.mmap file is a material transfer list file from Revit Structure to midas Gen.
The user can directly add or modify MaterialMap.mmap to specify material properties
imported in midas Gen.
Section transfer data are written in the following formats:

Material Type: Material type used in Revit Structure
Material Name: Material name used in Revit Structure
Standard: Material standard which will be used in midas Gen
Code: Concrete design standard for considering the change of modulus of elasticity. This
field is required only when the Standard is specified as KS(01RC).
DB Name: Material DB name which will be used in midas Gen
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Update Model from midas Gen

1.In order to update the Revit Structure model from midas Gen, click Add Ins > External 

Tools > Update Model from MIDAS/Gen. 

2.A dialog will pop up. If "Send Model to MIDAS/Gen" has been used during this session, 

the paths for the files are automatically set to be the same. If necessary, click Browse to 

change them. 

3.Click Update to start updating the model.
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Applicable data for MIDAS Link for Revit Structure

Note

1) In order to export point loads, line loads, or area loads to midas Gen, those loads need to be separately entered for each element. For example, if we
enter a line load to continuous beam (element no. 1 and 2), we need to enter the load to element no. 1 and 2 separately.

2) Area Load in Revit Structure is imported as Floor Load (Polygon-Length type) in midas Gen.

3) The name of Load Combination Usage specified in Revit Structure will determine the load combination tab in midas Gen. When the name of Load
Combination Usage is entered as Steel, Concrete, SRC or Footing, the combination shall be included in the Steel Design, Concrete Design, SRC Design or
Footing Design tab of Load Combination dialog box in midas Gen. For the other names of Load Combination Usage, the corresponding load
combinations will be included in General tab of Load Combination dialog box.

Category Features
Revit to 

midas Gen
Remark

Material

Concrete v

Steel v

Pre Cast Concrete v

Wood N/A

Glass N/A

Ston N/A

Metal N/A

Section

Concrete v

Steel v

SRC N/A

Member

Column
Vertical Column v

Only solid rectangular section is applicable.
Inclined Column v

Beam

Straight Beam v

Curved Beam N/A

Inclined Beam v

Wall

Straight Wall v

Curved Wall N/A

Inclined Wall N/A

Masonry Wall N/A

Wall Opening N/A

Brace v

Truss(Top chord, Bottom chord, and Web) v

Slab N/A

Foundation N/A

Boundary

Support(Hinge, Roller, Fixed) v

Beam End Release v

Section Offset N/A

Static Load

Self Weight N/A Load Nature Name : Dead

Dead Load v Load Nature Name : Dead

Live Load v Load Nature Name : Live

Wind Load v Load Nature Name : Wind

Seismic Load v Load Nature Name : Seismic

Temperature Load v Load Nature Name : Temperature

Snow Load v Load Nature Name : Snow

Accidental Load v Load Nature Name : Accidental

Live Load on the roof v Load Nature Name : Roof Live

Point Load , Hosted Point Load1) v

Line Load , Hosted Line Load1) v

Area Load 1), 2) v

Hosted Area Load 1) N/A

Load 
Combination

Load Combination 3) v
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What is Updated from midas Gen to Revit Structure

Here are the revisions that are detected and updated in the Revit model:

Sections

 If assigned section is changed to a pre-defined section in the model, the corresponding

element in Revit will be updated accordingly.

 If assigned section is changed to a new section in midas Gen, the corresponding element
in Revit will be assigned to a default section (arbitrary section which has a same material
type in a model).

Delete Elements

If an element is deleted in midas Gen, the corresponding element in Revit will be deleted
accordingly.

Move Elements

If an element is moved in midas Gen, the corresponding frame element or column in Revit
will be moved accordingly.

Add Elements

If a beam element (solid box section only) is newly added, a corresponding element in
Revit will be added accordingly.

Change Beta-Angle

If beta-angle in a beam element is changed, a corresponding element in Revit will be
updated accordingly.

Materials

If material data assigned to an element is modified, a corresponding element in Revit will

be assigned to a default material (arbitrary material existed in Revit).
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3. Pressure Type of Beam Loads

• “Uniform Pressure” and “Trapezoidal Pressure” type of Line Beam Loads and Element

Beam Loads have been implemented to consider the width of beam elements when

entering wind loads.

• This feature is useful to assign wind loads to the tapered girders (ex. longitudinal girders in

bridges).

Additional H 
to consider the additional height of the structures 

which was not included in the modeling (ex. guard fence)

Assign a beam load as a pressure load 
considering the beam width

Loads > Element Beam Loads

Loads > Line Beam Loads

Uniform Pressure type Trapezoidal Pressure type
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4. Improved Eccentricity Option in the Element Beam Load and Line Beam Load

• Eccentricity can be entered by the following 2 methods: 1) from the centroid, and 2) from

the offset point.

• In the previous version, the eccentricity was entered only from the centroid. In case of the

tapered section, beam loads with eccentricity can be easily entered from the offset point.

Loads > Element Beam Loads

Loads > Line Beam Loads

Enter the eccentricity from Offset (nodal position) 

for the tapered sections

Two methods to enter the eccentricity



Gen 2010 Pre/Post Processing Enhancements Gen 2010 (v2.1) Release Note

18 /32

5. Improved India Standard section DB

• New sections (Box, Pipe, and Angle) have been implemented in IS, IS1161, and IS808

section DB.

Model > Properties > Section

Box Section SHS

Pipe Section NB

Box Section RHS

Angle Section Data
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6. Changes in the Default Values of Stiffness Scale Factor 
in the Composite Section for Construction Stage

• In the SRC type section dialog box, the default value of “Combined Ratio of Conc.” has been

changed from “0.8” to “1.0” in order to prevent user’s confusion.

• In the Composite Section for Construction Stage dialog box, the default values of “Stiffness

Scale Factor” have been changed from “0.8” to “1.0”.

Model > Properties > Section 

Load > Construction Stage Analysis Data > Composite Section for Construction Stage
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7. Addition of Dimension Import

• Import dimension layers from AutoCAD DXF. Dimensions are displayed as guide lines on the

screen such as grid lines and it does not affect analysis results.

Model > Dimension



(1) Analysis Stop Option in the Pushover Analysis

(2) Improved Pushover Analysis Results

(3) Mander Model in the Inelastic Material Properties

(4) Improved MINEGOTTO-PINTO Steel Model

 List of Detailed Enhancements in Analysis
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1. Analysis Stop Option in the Pushover Analysis

Design > Pushover Analysis > Pushover Global Control 

Results > Deformations > Deformed Shape

Design  > Pushover Analysis > Pushover Hinge Result Table > Shear Yield Element

• Analysis Stop option in the Pushover Global Control: When a shear hinge occurs in the

selected member, the pushover analysis will be automatically terminated. In this case, the

analysis results can be examined up to the last pushover step.

• Element Yield Status display in the Deformed Shape: The yield status of components (Fx,

Fy & Fz, Mx, and My & Mz)by pushover analysis is produced. This option is useful in

verifying if a shear failure occurred in any element.

• Shear Yield Element table: The elements for which shear hinge occurred prior to the

moment hinges or axial hinges are plotted in a spreadsheet format table.
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2. Improved Pushover Analysis Results

• Pushover analysis results have been graphically improved in order to prevent the user’s

confusion.

• In FEMA and Eurocode type hinge, the hinge status of “C” point and “D” point is now

displayed separately. In the previous version, the hinge status of “C,D” was displayed after

the C point.

Result > Deformations > Deformed Shape

Design > Pushover Analysis > Pushover Hinge Status Result

Design > Pushover Analysis > Pushover Hinge Result Table > Beam Summary

Previous version New version

Beam Summary Table

Pushover Hinge Status Result

Previous version

New version
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3. Mander Model in the Inelastic Material Properties

• Mander Model has been added to model the behavior of concrete confined with steel

stirrups.

• The menu name, Fiber Material Properties, has been changed to Inelastic Material

Properties.

Model > Properties > Inelastic Material Properties
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4. Improved MINEGOTTO-PINTO Steel Model

• In MINEGOTTO-PINTO steel model, the equation for calculating the plastic strain, , has

been changed in order to enhance the convergence performance.

Model > Properties > Inelastic Material Properties 
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 List of Detailed Enhancements in Design part

(1) Slab Deflection Check considering Cracked Section

(2) Limiting Rebar Ratio

(3) Limiting Minimum Section Size

(4) Improved Concrete Code Design as per the Latest 
Italy NA of Eurocode2:04

(5) Improved Capacity Design for Walls

(6) Serviceability Checking as per TWN-LSD96 and TWN-
ASD96
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1. Slab Deflection Check considering Cracked Section

Design > Meshed Slab/Wall Design> Slab Serviceability Checking
Design > Meshed Slab/Wall Design > Perform Cracked Section Analysis
Design > Meshed Slab/Wall Design > Cracked Section Analysis Control

Deflections considering cracked section can be calculated in Slab Serviceability Checking. midas

Gen performs a cracked section analysis for the generated Crack Analysis Load Cases.

Deflection check considering long term effect can also be calculated by applying the creep

coefficient.

Therefore Ieff (effective moment of inertia) 
can be calculated from the following 
equation:

Where,

ζ is a distribution coefficient, given by the

following equation:

Members which are expected to crack, but may not be fully cracked, will behave in a manner

intermediate between the uncracked and fully cracked conditions and an adequate prediction

of behavior is given by the equation below based on the sub clause 7.4.3 (3) in EN1992-1-

1:2004. Following factors including the effective moment of inertia by elements for each

iteration step can be checked in "File Name_CSA.OUT" file.
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2. Limiting Rebar Ratio

In concrete code design as per Eurocode2:04 (Italy National Annex) and capacity design as

per Eurocode8:04 (Italy National Annex) and NTC2008, the user can select whether to

consider minimum rebar ratio limitation.

Limiting Rebar Ratio will be useful to find required rebar ratio regardless the minimum rebar

ratio limitation.

Design  > Concrete Code Design > Limiting Rebar Ratio

 Applied minimum rebar requirements
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3. Limiting Minimum Section Size

In concrete code design as per Eurocode2:04 (Italy National Annex) and IS 13920:1993, and

capacity design as per Eurocode8:04 (Italy National Annex) and NTC2008, the user can select

whether to consider the minimum section size.

Design  > Concrete Code Design > Limiting Minimum Section Size

 Applied minimum rebar requirements

(1) Eurocode2-1-1:04
- Beam: 120mm
- Column: 120mm
- Wall: 100mm
- Slab ; 200mm for SLS design crack control 
- Mat ; 200mm

(2) Eurocode8-1:04, NTC 2008
- Beam: bw≤min{bc+hw, 2bc} for DCM and DCH

200mm for DCH
- Column: 250mm 
- Wall:max(150mm, 1/20 x height)

(3) IS456:2000, IS13920:1993
- Beam: w/d ≥ 0.3, min{bc, hc} ≥ 200mm, d ≤ 1/4 x lcr
- Column: min{bc, hc} ≥ 200mm, dc/db ≥ 0.4 
If the column height is larger than 5m or unbraced length is larger than 
4m, section dimension should be larger than 300mm. 

- Wall: t ≥ 150mm 



Gen 2010 Design Enhancements Gen 2010 (v2.1) Release Note

30 /32

4. Improved Concrete Code Design
as per the Latest Italy NA of Eurocode2:04 

• The default values for the stress parameter (k4) has been changed based on the

latest Italy national annex. (1.0 in the previous version, 0.9 in the new version)

• The equation of the strength reduction factor, ν, to calculate the shear force has been

changed based on the latest Italy national annex.

Design > Concrete Design Parameter > Design Code

Design > Concrete Design Parameter > Serviceability Parameters

Design > Concrete Code Design > Beam Design

 Previous version
 New version

Eurocde2:04, 6.2.2(6)

… The shear force VEd, calculated without reduction by β, should however always satisfy 
the condition 

where ν is a strength reduction factor for concrete cracked in shear…
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5. Improved Capacity Design for Walls

• In the Capacity Design of walls, the magnification factor, ε, has been corrected to

consider the design bending moment (MEd) and the design flexural resistance (MRd) at

the base of the wall. In the previous version the design bending moment (MEd) and

the design flexural resistance (MRd) were calculated at the bottom of the walls at

each story.

ε is the magnification factor, calculated from expression (5.25), but not less than 1,5: 

Eurocde8:04, 5.4.2.4, Figure 5.4

Eurocde8:04, 5.5.2.4.1, equation (5.25)

Design > Concrete Design Parameter > Design Code

Design > Concrete Code Design > Wall Design



Gen 2010 Design Enhancements Gen 2010 (v2.1) Release Note

32 /32

6. Serviceability Checking as per TWN-LSD96 and TWN-ASD96

• In the Steel Code Check as per TWN-LSD96 and TWN-ASD96, serviceability check has

been added for beam and column members.

• In the Serviceability Parameters, the user can specify the limit values for the deflection

check.

Design > Steel Design Parameter > Design Code

Design > Steel Design Parameter > Serviceability Parameters

Design > Steel Code Check

Graphical Results

Detailed Results

Steel Code Checking Result Dialog Box


