
MIDAS/Gen V.720 Enhancements

Major Enhancements

Modeling & Analysis Part

Results Part

• Wind Load Calculation Standard Eurocode 1 (2005) has been added

• Static Seismic Load Calculation Standard Eurocode 8 (2004) has been added

• Masonry Material Models have been added

• Addition of a function to enable the input of Eccentric Beam Loads

• Enhancements of Pushover Analysis function

• Display of Moment Combination in Plate Force/Moment Result

• Enhancements of Pushover Analysis Result

• Enhancements of Story Result Tables

• Display Story Shear Force for each Mode 



Major Enhancements

Design Part

• Serviceability Checks as per Eurocode 2 & 3 

• Assign Rebars by Members

• Disregard of Extremely Small Compression/Tension in Nonlinear Members

• Enhancements of Concrete Design Result (Rebar, Area and Ratio separately displayed)

• Enhancements of Steel Design

• Enhancements of Orthogonal Effect in Seismic Load Cases

Miscellaneous

• Enhancements of Display function

• Graphic Option added in Preferences Menu

• Save all Graphic Design Results as a graphic file format



Modeling & Analysis Part

Contents

(1) Wind Load Calculation Standard Eurocode 1 (2005) has been added 

(2) Static Seismic Load Calculation Standard Eurocode 8 (2004) has been added

(4) Addition of a function to enable the input of Eccentric Beam Loads

(5) Enhancements of Pushover Analysis function

(3) Masonry Material Models have been added



Modeling & Analysis Part

(1) Wind Load Calculation Standard Eurocode 1 (2005) has been added

● MIDAS/Gen Online Manual V.720

- Refer to Loads > Lateral Loads > Wind Load

Loads > Lateral Loads > Wind Load

Reference

“Parameters for Mean Wind Velocity” 
dialog box

Auto-calculation of 

Gust effect factor

Gust effect factor and 

auto-calculated 

parameters

Wind loads auto-calculated 

as per Eurocode (2005)



Modeling & Analysis Part

(2) Static Seismic Load Calculation Standard Eurocode 8 (2004) has been added 

● MIDAS/Gen Online Manual V.720

- Refer to Loads > Lateral Loads > Static Seismic Load

Loads > Lateral Loads > Static Seismic Load

Reference

Seismic Load Parameters

1. Ground Type
: A, B, C, D, E, S1, S2

2. Soil Factor (S)
: S>0

3. Design ground acceleration (Ag)
: Ag > 0

4. Behavior factor (q) 
: q> 0

5. Lower bound factor (b) 
: Lower bound factor for design spectrum 
(b> 0)

6. Importance Factor (I) 

Static Seismic Loads auto-calculated 

as per Eurocode (2004) 



Modeling & Analysis Part

(3) Masonry Material Models have been added

● Applicable only to 8-node Solid elements 

● MIDAS/Gen Online Manual V.720

- Refer to Model > Property > Plastic Material

Model > Property > Plastic Material

Comment & Reference

Related post-processor

● Results > Stresses > Solid Stress

Brick Material Bed Joint Material Head Joint Material Geometry of Masonry Panel

Yield status 

at each step



Modeling & Analysis Part

(4) Addition of a function to enable the input of Eccentric Beam Loads 

● Eccentric beam loads can be inputted in ECS or GCS.

● Eccentric beam load is applied as a concentrated load and 

a moment due to eccentricity internally by the 

program.

● MIDAS/Gen Online Manual V.720

- Refer to Loads > Element Beam Load & Line Beam 

Load

Load >  Element Beam Loads

Input of Eccentric Beam Loads

Example of input of 

eccentric beam load

Applied eccentric loads

Comments & Reference

Load >  Line Beam Loads



Modeling & Analysis Part

(5) Enhancements of Pushover Analysis function

● User can define the Shear Spring Location

(the option to consider the additional moment occurring 

at the end of the element due to shear deformation).

● MIDAS/Gen Online Manual V.720

- Refer to Model > Boundary > General Link Property 

Model > Boundary > General Link Property

A. Pushover Analysis function can be applied to Spring type General Link Elements
– Elastic property

Applicable to Spring Type only

Enter elastic property of Spring

Comment & Reference

Enter Shear Spring Location



Modeling & Analysis Part

Model > Boundary > General Link Property

B. Pushover Analysis function can be applied to Inelastic Hinges – Inelastic property

Model > Property > Inelastic Hinge Property

● MIDAS/Gen Online Manual V.720

- Refer to Model > Property > Inelastic Hinge Property

- Refer to Model > Boundary > General Link Property 

Comment & Reference
Spring Type

Applicable to inelastic hinges

Applicable only when 

User Input, Spring and None 

types are selected

All Hysteresis Models built-in 

MIDAS/Gen can be used



Modeling & Analysis Part

C. Enhancements of Plastic Hinges

i. Disequilibrium force in a member has been resolved

ii. Improvement in convergence of 

pushover analysis using wall 

elements
M  M 

EI HingeF F F 
EI HingeF F F 

Pushover Analysis

Multi-linear FEMA

Flexural member

Inelastic hinge
At both ends of a 

member

At both ends of a 

member

Plastic length of 

a member
1/6L from both ends 0

Flexibility of a 

member

a. FEMA Type: Enable the user to define the initial stiffness 

of flexural member to be used in inelastic analysis

b. Multi-linear Type: Distributed hinge type for inelastic 

time history analysis has been added

Define initial 

stiffness of 

flexural member



Modeling & Analysis Part

D. Enhancements in Convergence Problem and Reliability of Pushover Analysis

Design > Pushover Analysis > Pushover Analysis Control

i. Convergence Criteria, Force Norm and Energy Norm have been added

Force Norm and Energy Norm added

ii. Residual disequilibrium force after the convergence for each increment 

is determined has been resolved

iii. Revision of hysteresis routine – Unloading routine added

iiii. Enhancements of algorithm to improve other convergence problem

● MIDAS/Gen Online Manual V.720

- Refer to Design > Pushover Analysis > Pushover 

Analysis Control

Reference



Results Part

Contents

(2) Enhancements of Pushover Analysis Result

(3) Enhancements of Story Result Tables

(4) Display Story Shear Force for each Mode

(1) Display of Moment Combination in Plate Force/Moment Result



Results Part

● MIDAS/Gen V.720 Online Manual

- Refer to Results > Forces > Plate Force 

Reference

(1) Display of Moment Combination in Plate Force/Moment Result

Results > Forces > Plate Forces / Moments

Mxx = 1.0
Myy = 0.5

Mxx = 1.0
Myy = 1.0

Mxx = 1.0
Myy = 0.3



Results Part

(2) Enhancements of Pushover Analysis Result

Results > Deformations > Deformed Shape

Related Functions

● Design > Pushover Analysis > Hinge Status Table

● MIDAS/Gen V.720 Online Manual

Refer to Results > Deformations > Deformed Shape

Reference

Display Multi-linear 

type hinge

Display FEMA 

type hinge

A. Display Hinge Status of General Link Elements



Results Part

(3) Enhancements of Story Result Tables

● MIDAS/Gen Online Manual V.720

- Refer to Results > Result Tables > Story  Shear Force 

Ratio 

● Story Shear Force due to RS loads is calculated by 

combining the story shear forces of each mode using 

the modal combination method.

Related Functions

● Model > Buildong >  Control Data

- Story Shear Force Ratio Check On

Reference

A. The method of calculating the Story Shear Force Ratio due to Response Spectrum 
loads has been changed

Results > Result Tables > Story

> Story Shear Force Ratio

Sum of the story shear 
forces that Frame and Wall 
share respectively

The sum of the ratios 
of Frame and Wall is 1



Results Part

● If Story Drift is negative (-), the stiffness of the 

corresponding story is displayed with "-“.

B. Enhancements of Stiffness Irregularity Check Table

Results > Result Tables > Story > Stiffness Irregularity Check

Example: Stiffness Irregularity Check

Module not defined

Module defined

Comment



Results Part

Related Functions

● Story Result Tables that display NG in the Remark 

column

- Story Drift

- Story Shear Force Coefficient

- Torsional Irregularity Check

- Stiffness Irregularity Check

- Weight Irregularity Check 

- Capacity Irregularity Check

C. NG is displayed in red in the Remark column of the Story Result Tables

Results > Result Tables > Story Tables

Example: Story Drift

Example: Capacity Irregularity Check



Results Part

D. Application of Module function extended to more Story Result Tables

Results > Result Tables > Story Tables

Application of Module function Remark

Story Drift Already existed

Story Displacement Already existed

Story Shear Forces (Response Spectrum Analysis) Newly added

Story Mode Shape Already existed

Story Eccentricity Newly added

Story Shear Force Ratio Newly added

Torsional Amplification Factor Already existed

Overturning Moment Already existed

Story Axial Force Sum Already existed

Stability Coefficient Already existed

Torsional Irregularity Check Already existed

Stiffness Irregularity Check Already existed

Capacity Irregularity Check Already existed



Results Part

● MIDAS/Gen Online Manual V.720

- Results > Result Tables > Story Drift

- Results > Result Tables 

> Story Drift (Time History Analysis)

- Results > Result Tables 

> Story Shear (Response Spectrum Analysis)

Reference

E. Level column removed from the Story Drift and Story Shear Force Coefficient 
Tables

Results > Result Tables > Story > Story Drift, Story Drift (Time History Analysis), Story Shear 

(Response Spectrum Analysis) - Story Shear Force Coefficient

Story Level column removed

Level (Unit) removed

Level (Unit) removed



Results Part

Related Functions

● Loads > Response Spectrum Analysis Data > 

Response Spectrum Load Case

● Analysis > Eigenvalue Analysis Control

● Results >  Result Tables > Story > 

Story Shear Force Ratio, 

Story Shear (Response Spectrum Analysis)

(4) Display Story Shear Force for each Mode

Results > Result Text Output (*. MSR, *. GA1)

*. MSR file



Design Part

Contents

(1) Serviceability Checks as per Eurocode 2 & 3 

(3) Disregard of Extremely Small Compression/Tension in Nonlinear Members

(4) Enhancements of Concrete Design Result (Rebar, Area and Ratio separately 
displayed)

(5) Enhancements of Steel Design

(6) Enhancements of Orthogonal Effect in Seismic Load Cases

(2) Assign Rebars by Members



Design Part

(1) Serviceability Checks as per Eurocode 2 & 3

Results > Combinations

A. Generate Load Combinations for Serviceability Checks

Input load factors for 
serviceability checks

Auto-generation of load 
combinations as per Eurocode 2 

for serviceability check Auto-generation of load 
combinations as per Eurocode 3 

for serviceability check ● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for Serviceability Check as per 

Eurocode 2] in Design > Concrete Code Checking > Beam 

Checking

- Refer to [Procedure for Serviceability Check as per 

Eurocode 3] in Design > Steel Code Check

Related Function

● Design > General Design Parameters > 

Serviceability Load Combination Type

References



Design Part

B. Enter long term and short term Elastic Modulus Ratios

● Short/Long Term Elasticity Ratio 

- Default for Short Term: Es/Ec

- Default for Long Term: 2(Es/Ec)

● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for Serviceability Check as per 

Eurocode 2] in Design > Concrete Code Checking > Beam 

Checking

- Refer to [Procedure for Serviceability Check as per 

Eurocode 3] in Design > Steel Code Check 

Comment & References

Design > Concrete Code Design > Modify Concrete Material



Design Part

C. Assign or check Serviceability Load Combination Type

● Once serviceability load combinations are created by using 

Auto Generation of Results > Combination, the created 

load combinations are automatically classified into 

Serviceability Load Combination Type dialog box 

according to types. 

● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for Serviceability Check as per 

Eurocode 2] in Design > Concrete Code Checking > Beam 

Checking 

- Refer to [Procedure for Serviceability Check as per 

Eurocode 3] in Design > Steel Code Check

Comment & References

Design > General Design Parameters > Serviceability Load Combination Type

Load Combination Types for 
Serviceability Checks

1. Quasi-permanent

2. Frequent

3. Characteristic

Related Functions

● Results > Combinations



Design Part

D. Enter Parameters for Serviceability Checks

● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for Serviceability Check as per 

Eurocode 2] in Design > Concrete Code Checking > Beam 

Checking

- Refer to [Procedure for Serviceability Check as per 

Eurocode 3] in Design > Steel Code Check 

References

Design > Concrete Design Parameters > Serviceability Parameters

Related Functions

● Design > Concrete Code Checking > Beam Checking

● Design > Steel Code Check

Design > Steel Design Parameters > Serviceability Parameters

Concrete

Parameters for Serviceability Checks

1. Concrete (Beam)
- Crack Control
- Deflection Control

2. Steel (Beam, Column)
- Deflection Control



Design Part

E. Serviceability Checking Results as per Eurocode 2

Design > Concrete Code Checking > Beam Checking

Produce Crack Control & 
Deflection Control results

Both ‘Strength’ (Stress) and ‘Serviceability’ (Crack) results are 
produced in the Detail Report

● Graphic Report

- Crack Control

- Deflection Control

● Detail Report

- Stress (Strength Results)

- Crack (Serviceability Results)

● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for 

Serviceability Check as per Eurocode 

2] in Design > Concrete Code 

Checking > Beam Checking

- Refer to [Procedure for 

Serviceability Check as per Eurocode 

3] in Design > Steel Code Check

Comments & References



Design Part

F. Serviceability Checking Results as per Eurocode 3

Design > Steel Code Check

● Graphic Report

- Deflection Checking Results

● Detail Report

- Check Deflection

● MIDAS/Gen V.720 Online Manual

- Refer to [Procedure for Serviceability 

Check as per Eurocode 2] in Design > 

Concrete Code Checking > Beam Checking

- Refer to [Procedure for Serviceability 

Check as per Eurocode 3] in Design > Steel 

Code Check

Comments & References

Produce ‘Deflection Checking Results’

Display ‘Check Deflection’ results



Design Part

(2) Assign Rebars by Members

Design > Concrete Design Parameters > Design Criteria for Rebar by Members

● MIDAS/Gen V.720 Online Manual

- Design > Concrete Design Parameters 

> Design Criteria for Rebar by Members

- Design > Concrete Design Parameters 

> Concrete Design Tables >  Design Criteria for Rebar by 

Members

● While ‘Design Criteria for Rebars’ enables the user to 

assign rebars by sections,  ‘Design Criteria for Rebar by 

Members’ enables the user to assign rebars by members. 

‘Design Criteria for Rebar by Members’ precedes ‘Design 

Criteria for Rebars’ when both are assigned. 

Design > Concrete Design Parameters 

> Concrete Design Tables > Design Criteria for Rebar by Members

Beam Rebar Table

Column/Brace Rebar Table

Wall Rebar Table

Comment & References



Design Part

(3) Disregard of Extremely Small Compression/Tension in Nonlinear Members

Design > Steel Code Check

Related Functions

● Model > Elements > Create Element 

Tension Only/Hook/Cable, Compression Only/Gab

● Load >

Create Load Cases Using Load Combinations

● Analysis > Main Control Data

Design > Concrete Code Design > RC, Column, Wall, Brace Design

Design > SRC Code Check > Column Checking

Revision of V720

In cases where tension-only/compression-only elements have extremely small 
compression/tension, the compression/tension forces are ignored in the design 
process.

Steel Design
- Compression/tension forces are ignored if they are less than 1/10000 of (Steel 
Sectional Area × Fy).
- This is identically applied to tapered sections and the area is measured at the 
section where the strength check is to be performed.

RC Design
- Compression/tension forces are ignored if they are less than 1/10000 of 
(Concrete Area × Fck).
- Reinforcement is not taken into account since the forces are calculated before 
design.

SRC Design
- Compression/tension forces are ignored if they are less than 1/10000 of (Steel 
Sectional Area × Fy).
- In SRC Design, it is common to design in a way that only the steel section can 
resist compression and tension



Design Part

(4) Enhancements of Concrete Design Result (Rebar, Area and Ratio separately displayed)

● MIDAS/Gen V.720 Online Manual

- Refer to Design > Concrete Design Result

Reference

Design > Concrete Design Result

Display Ratio 
separately

Display Rebar 

Display Area 

Display Ratio 



Design Part

(5) Enhancements of Steel Design

A. ‘Change Steel Properties Dialog’ displays code checking results for all Properties

Design > Steel Code Check

B. Revision of Steel Code Checking Detail Calculations

Revision of V720

Old Version: Detail report used to display the calculations corresponding to the location of member and load combination,

which produced the most critical combined stress.

New Version: Detail report displays the calculations corresponding to the location of member, which produces the more

critical one of the most unfavorable combined stress and the most unfavorable shear stress.

Produce the code checking 
results for all properties 
in a text format



Design Part

(6) Enhancements of Orthogonal Effect  in Seismic Load Cases

Related Function

● Results > Combinations 

Set Load Cases for Orthogonal Group

V702

V720

- While generating static seismic load combinations with Orthogonal Effect considered, only one load combination was generated. For example, only 

one of [E(X), E(Y)], [E(Y),E(Z)] and [E(Z),E(X)] could be generated. (This was identically applied to Response Spectrum Loads.)

- [E(X), E(Y)], [E(Y),E(Z)] and [E(Z),E(X)] can be all generated. (This is identically applied to Response Spectrum Loads.)

Only one load combination could be 
generated for static seismic load and 
response spectrum load, respectively

Up to 3 load combinations can be 
generated for static seismic load and 
response spectrum load, respectively

V710 (R2) V710 (R3)



Miscellaneous

Contents

(1) Enhancements of Display function

(2) Graphics Option added in Preferences Menu

(3) Save all Graphic Design Results as a graphic file format



Miscellaneous

(1) Enhancements of Display function

● MIDAS/Gen V.712 Online Manual

- Refer to View > Display Option 

View > Display Option

Related Functions

● Results > Deformations > Deformed Shape

- Inelastic Time History Analysis Result 

- Pushover Analysis Result

A. Hinge Size can be controlled

Control Sizes

Reference



Miscellaneous

● MIDAS/Gen V.712 Online Manual

- Refer to View > Display 

View > Display

Related Functions

● Model > Property > Sections

B. Simultaneously display the Section Shape and the Section Property Name

Display Property Name and Section Shape simultaneously

Reference



Miscellaneous

(2) Graphics Option added in Preferences Menu

● MIDAS/Gen V.720 Online Manual

- Refer to Tools > Preference 

Reference

Tools > Preference

Stream Buffer Size 
Specify the Buffer Size according to the configuration of 
the graphic card

Enable Vector-Based Print Out 
Reduce time for printout using the Vector-Based Engine 
of low resolution 

Enable Low Resolution Print Out 
Optimize the background when the Vector-Based Print 
Out option is enabled



Miscellaneous

(3) Save all Graphic Design Results as a graphic file format

Design > Design Result Dialog & Code Check Result Dialog

Revision of V720 

Old Version: Save the graphic design result of a single member or property

New Version: Save the graphic design results of a lot of members or properties


