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Progettazione sismica di una struttura in
calcestruzzo armato

Introduzione
Il problema trattato in questo esempio sviluppa il progetto di un edificio a struttura in
calcestruzzo armato soggetto a carichi di piano, carichi da vento e sollecitazioni sismiche

Descrizione
Dati di progetto sismico
- Sistema duale (pareti strutturali in calcestruzzo armato con telaio reagente a momento)

nella direzione trasversale Y
- Telaio di reazione a momento nella direzione longitudinale X
- Assegnazione ad una zona ad alta sismicità

Metodologia
- Spettro di analisi di risposta
- Analisi P-Delta

Modello

Figura 1 : Costruzione in calcestruzzo armato
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Figura 2 : Pianta tipica di un piano

Figura 3 : Sezione longitudinale
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Procedura di disegno

1. Introduzione di sezioni e proprietà dei materiali

Materiale
- Calcestruzzo fc’ = 4,000 psi
- Rinforzo fy = 60,000 psi

Sezioni
- Colonne di bordo 24

�

24 in.
- Colonne interne 30

�

30 in.
- Travi 20

�

24 in.
- Pareti spessore 18 in. (In-plane & Out-of-plane)

Figura 4 : Introduzione materiali e sezioni
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2. Creazione del modello

Unità : Length > ft

     Settare UCS al piano X-Y

Origine : 0, 0, 16

Change View Direction > (on)

Settare le linee griglia

     Grid Name = 2F

X-Grid Lines

Relative > (on)

‘7@26’

Y-Grid Lines

Relative > (on)

     ‘3@22’

     Add/Modify Grid Lines

     Define Grids

                  Linee griglia, snap alle linee griglia  (settare su on)

Figura 5 : Creazione delle linee griglia
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Figura 5 : Linee griglia nel piano X-Y

Generazione di un piano

Visualizzazione linee nascoste,       Numerazione nodi,        Numerazione elementi (on)

Crea elementi

Element Type = General Beam / Tapered Beam

Section Name = 3 : travi

Si disegnino gli elementi come sotto indicato ( Figura 6)

Figura 6 : Piano
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Generazione colonne

 Passare a GCS

Selezionare tutto

Estrudi Elementi

Node ®  Line Element

Reverse I-J > (on)

Element Type = Beam

Material =  1 : Grade C4000

Section = 1 : Edge column

dx, dy, dz = 0, 0, -16

Figura 7 : Generazione Colonne

Cambiare le proprietà delle colonne interne

Work > Properties > Section : 1 : Edge column = Active

      Display > Property > Property Name > (on)

 Vista isometrica ( Figura 8)

Vista dall’alto >        Finestra di selezione > Selezionare le colonne interne

Work > Properties > Section = 2 : colonne interne

Drag & Drop ( Figura 9)
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Figura 8 : Disattivare le travi

Figura 9 : operazione di “Drag & Drop”  Proprietà colonne interne

�

�

�
Assign

DropDrag
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Generazione pareti

Superfici nascoste (off) ; Numerazione nodi (on)

      Display > Property > Property Name > (off)

 Select Window (Refer Figura 10)

     Active

Create Elements

Element Type : Wall

Membrane > (on)

Wall ID > Auto Inc. > 1

Material Name > 1:Grade C4000

Thickness > 1:1.5000

Intersect Node > (on)

Nodal Connectivity > 50, 42, 10, 18 (Refer      on Figura 11)

Select Single > Wall Element 1

Translate Element > Copy

Equal Distance (dx, dy, dz) > 130, 0, 0  

Wall ID Increment = 1

Figura 10 : Posizionamento degli elementi parete

�
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Figura 11 : Connessione ai nodi per l’elemento parete

Figura 12 : Generazione dell’elemento parete

�

1

1
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Generazione edificio

Selezionare tutto

Model > Building > Building Generation

Number of Copies = 11

Distance(Global Z) = 12

Figura 13 : Generazione dell’edificio
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Generazione dei dati relativi ai piani

L’operazione permette a /Gen di riconoscere in maniera semi automatica i singoli piani.

Questo permette notevoli facilitazioni nella generazione di dati per l’analisi sismica

e dei report post analisi.

Model > Building > Story

Figura 14 : Generazione dei dati di piano



Progettazione sismica per una struttura in calcestruzzo armato

13

3. Condizioni di vincolo
Le estremità inferiori delle colonne sono assunte incastrate

Model > Boundary > Supports
D – All > (on)
R – All > (on)

  Select Window

Figura 15 : Vincoli (supports)
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4. Introduzione dei dati relativi ai carichi

Load > Static Load Cases

- Dead Load
- Live Load
- Wind Load (X-direction)
- Wind Load (Y-direction)
- Earthquake Load (X-direction, Eccentricity direction-Positive)
- Earthquake Load (X-direction, Eccentricity direction-Negative)
- Earthquake Load (Y-direction, Eccentricity direction-Positive)
- Earthquake Load (Y-direction, Eccentricity direction-Negative)

Figura 16 : Dati relativi alle condizioni elementari di carico statico (Static Load Cases)
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Peso proprio

Load > Self Weight

Z =  -1

Figura 17 : Carico da peso proprio
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Carichi di piano (floor load)

Carico > Definisci carichi di piano
- Name > Typical Floor : DL = -30 psf, LL = -75 psf
- Name > Roof Level : DL = -10 psf, LL = -20 psf

Load > Assign Floor Load
- Load Type > Typical Floor
- Two Way Distribution
- Copy Floor Load  > (on)
- Axis > z (on)
- Distance > 10@12
- Assign Nodes Defining Loading Area > (1, 2, 32, 25)

Similarly, assign floor load at roof level :
- Load Type > Roof Level
- Copy Floor Load  > (off)
- Assign Nodes Defining Loading Area > (386, 387, 417, 410)

Figura 18 : Assegnazione dei carichi di piano

�
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Figura 19 : Distribuzione di un carico di piano
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Carichi da vento

Load > Lateral Loads > Wind Loads

- Load Case Name > WX
- Wind Load Code > IBC2000 (ASCE7-98)
- Simplified Procedure > (on)
- Basic Wind Speed > 85 mile/h
- Importance Factor > 1
- Exposure Category > B
- Scale Factor in Global X > 1
- Scale Factor in Global Y > 0

- Load Case Name > WY
- Scale Factor in Global X > 0
- Scale Factor in Global Y > 1

Figura 20 : Introduzione dei carichi da vento
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Conversione in masse del peso del modello e dei carichi

Model > Structure Type
- Structure Type > 3-D (on)
- Convert to X, Y (on)
- Gravity Acceleration > 32.1719 (ft/sec2)

Figura 21 : Conversione in massa del peso del modello

Model > Masses > Loads to Masses
- Mass Direction > X, Y (on)
- Load Type for Converting > All (on)
- Gravity > 32.1719 (ft/sec2)
- Load Case > DL
- Scale Factor > 1

- Load Case > LL
- Scale Factor > 0.25

Figura 22 : Conversione dei carichi del modello in masse
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Carichi sismici statici equivalenti

Load > Lateral Loads > Static Seismic Loads

- Load Case Name > EXP
- Seismic Load Code > IBC2000 (ASCE7-98)
- Seismic Design Category > E
- Site Class > C
- Ss = 1.0
- S1 = 0.3
- Importance Factor (I) = 1
- Period (Code) > X-Dir. = 1.2 ; Y-Dir. = 0
- Response Modification Coef. (R) > X-Dir. = 8 (Telaio speciale reagente a momento),

Y-Dir. = 8 (Sistema duale: pareti in calcestruzzo
speciale armato con telaio reagente a momento)

- Scale Factor in Global X = 1
- Scale Factor in Global Y = 0
- Accidental Eccentricity in X-direction > Positive (on)
- Accidental Eccentricity in Y-direction > Positive (on)

- Load Case Name > EXN
- Period (Code) > X-Dir. = 1.2 ; Y-Dir. = 0
- Scale Factor in Global X = 1
- Scale Factor in Global Y = 0
- Accidental Eccentricity in X-direction > Negative (on)
- Accidental Eccentricity in Y-direction > Negative (on)

- Load Case Name > EYP
- Period (Code) > X-Dir. = 0 ; Y-Dir. = 1.2
- Scale Factor in Global X = 0
- Scale Factor in Global Y = 1
- Accidental Eccentricity in X-direction > Positive (on)
- Accidental Eccentricity in Y-direction > Positive (on)

- Load Case Name > EYN
- Period (Code) > X-Dir. = 0 ; Y-Dir. = 1.2
- Scale Factor in Global X = 0
- Scale Factor in Global Y = 1
- Accidental Eccentricity in X-direction > Negative (on)
- Accidental Eccentricity in Y-direction > Negative (on)
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Figura 23 : Introduzione dei carichi sismici statici
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Definizione dello Spettro di risposta
Si affronta ora la definizione dello Spettro di risposta e la creazione delle Condizioni

elementari di carico determinate dall’analisi con spettro di risposta.

Load > Response Spectrum Analysis Data > Response Spectrum Functions

Design Spectrum
- Design Spectrum > IBC2000 (ASCE7-98)
- Site Class > C
- Ss = 1.0
- S1 = 0.3

Figura 24 : Spettro di risposta
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Load > Response Spectrum Analysis Data > Response Spectrum Load Cases
- Load Case Name > RX
- Direction > X-Y
- Excitation Angle = 0 (deg.)
- Scale Factor (I/R) > 1/8 = 0.125
- Period Modification Factor = 1
- Function Name (Damping Ratio) > IBC2000(ASCE7-98) (0.05) > (on)
- Interpolation of Spectral Data > Linear (on)
- Accidental Eccentricity > (on)

- Load Case Name > RY
- Excitation Angle = 90 (deg.)

Figura 25 : Definizione della Condiz. Elementare di carico per spettro di risposta
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5. Analisi

Analysis > P-Delta Analysis Control
- Number of Iterations = 5
- Convergence Tolerance = 1e-005
- P-Delta Combination > Load Case > DL ; Scale Factor > 1

- P-Delta Combination > Load Case > LL ; Scale Factor = 0.25

Analysis > Eigenvalue Analysis Control
- Type of Analysis > Eigen Vectors (on) > Subspace Iteration (on)
- Number of Frequencies = 10
- Number of Iterations = 20
- Subspace Dimension = 0
- Convergence Tolerance = 1e-010

Analysis > Response Spectrum Analysis Control
- Modal Combination Type > SRSS

Lanciare l’analisi

Figura 27 : controllo di analisi P-Delta, autovalori e spettro di analisi di risposta
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6. Introduzione dati per la fase di Design (vertifica/progetto)
Results > Combinations
Concrete Design > Auto Generation
- Option > Add (on)
- Design Code > ACI318-02
- Scale Up Factor = 1.48 ; RX
- Scale Up Factor = 1 ; RY

Figura 28 : Generazione delle combinazioni di carichi per la progettazione in CA
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Confrontare RX (RY) con EX (EY)

RX (RY):
Results > Result Tables > Story > Story Shear (Spettro di analisi di risposta)
- Spectrum Load Cases > RX(RS) (on) & RY(RS) (on)
- Shear Force (Senza molle)

                     

Figura 29 : Taglio di piano (analisi con Spettro di Risposta)

EX (EY):
Load > Lateral Loads > Static Seismic Loads
Load Case > EXP > Modify > Seismic Load Profile
- Story Shear (on)

Similmente, selezionare i carichi EXN, EYP & EYN

Figura 30 : Taglio di piano (Carichi statici sismici)
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Design > General Design Parameter >Definition of Frame
- X-direction > Unbraced | Sway (on)
- Y-direction > Braced | Non-Sway (on)
- Design Type > 3-D
- Auto Calculate Effective Length Factors > (on)

Figura 31 : Definizione del telaio

Design > General Design Parameter > Modify Live Load Reduction Factor
General Tab

- Option > Add/Replace (on)
- Applied Components > Axial Force (on)
- Top View > Select Window

- Interior columns: Reduction Factor = 0.56

- Edge column: Reduction Factor = 0.69

- Corner column: Reduction Factor = 0.88

Figura 32 : Modifica del coefficiente di riduzione per Carichi Accidentali
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- Unbraced Length (L, Lb)
- Option > Add/Replace (on)
- Unbraced Length > Ly=0 ; Lx=0
- Laterally Unbraced Length > Do not consider (on)
- Select All

- Equivalent Moment Correction Factor (Cm)
- Option > Add/Replace (on)
- Moment Factor > Calculate by Program (on)
- Select All

Figura 34 : correzione del momento equivalente

Figura 33 : Lunghezza libera di inflessione

Design > Concrete Design Parameter > Design Code
- Design Code > ACI318-02
- Apply Special Provisions for Seismic Design > (on)
- Select Frame Type > Special Moment Frames (on)

Figura 35 : Codice di Design per la progettazione del calcestruzzo
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Design > Concrete Design Parameter > Strength Reduction Factors
- Update By Code

Figura 36 : Coefficienti di riduzione di resistenza

Design > Concrete Design Parameter > Design Criteria for Rebars (Refer Figura 37)

Figura 37 : Criteri di progetto delle barre di armatura
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Design > Concrete Design Parameter > Modify Concrete Materials

Select material ID #1
Rebar Selection
- Code > ASTM (RC)
- Grade of Main Rebar > Grade 60
- Grade of Sub-Rebar > Grade 40

Figura 38 : Modifica dei materiali calcestruzzo
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7. Output dati di progetto

Design > Concrete Code Design > Beam Design
Sorted by > Member (on) 

Figura 39 : Progettazione travi in calcestruzzo

Design > Concrete Code Design > Column Design
Sorted by > Member (on) 

Figura 40 : progettazione colonne in calcestruzzo
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Design > Concrete Code Design > Wall Design
Sorted by > Wall ID + Story (on) 
SEL (Select) > WID (Wall ID) = 1 ; Story = 1F
Graphic

Figura 41 : Progettazione pareti in calcestruzzo
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Figura 42 : Tipico Output di progettazione per parete in calcestruzzo
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8. Costruzione per fasi e valutazioni reologiche

Aprire il file “Seismic-RC” e salvarlo come “Seismic-RC_Stage”.

Portare le unità di misura a  “kips” e  “in”.

8.1. Definizione di proprietà dei materiali dipendenti dal tempo

Model>Properties>Time Dependent Material (Creep/Shrinkage)

Nome: C4000
Codice: CEB-FIP
Tensione di compressione del calcestruzzo all’età di 28 giorni: 4
Dimensione fittizia (2Ac/u) (Notational Size) dei membri: 1
Età del calcestruzzo all’inizio del ritiro: 3
Tipo di cemento: Normale o a presa rapida (on)

Controllare I coefficienti di creep (viscosità) e I grafici di deformazione da shrinkage (ritiro)
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Model>Properties>Time Dependent Material (Comp. Strength)

Name: C4000
Type: Code (on)
Code: CEB-FIP
Concrete Compressive Strength at 28 Days: 4
Cement Types: N, R: 0.25



Progettazione sismica per una struttura in calcestruzzo armato

37

Model>Properties>Time Dependent Material Link

Time Dependent Material Type> Creep/Shrinkage: C4000, Comp. Strength: C4000

Materials: 1:Grade C4000  Selected Materials
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Model>Properties>Change Element Dependent Material Property
Notational Size of Member> Auto Calculate  ;  Code: CEB-FIP

 Select All

controllare la Dimensione fittizia (2Ac/u) (Notational Size) dei membri cliccando su .
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8.2. Comporre la costruzione per fasi usando i Wizard

Load>Construction Stage Analysis Data>Construction Stage Wizard for Building Structure

LoadCase: DL  ;  Story Incr.: 1  ;  Stage Duration: 7  ;  Member Age: 7
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Controllare I carichi nella costruzione per fasi.

Display  > Load > Floor Load Name
Controllare struttura, condizioni al contorno e gruppi di carico dal menu  gruppo ad albero.
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8.3. Inserire I dati di controllo nella costruzione per fasi

Analysis> Construction Stage Analysis Control>
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8.4. Lanciare l’analisi

Rimuovere il P-Delta Analysis Control Data; la costruzione per fasi non può essere eseguita
contemporaneamente all’analisi P-Delta nella versione  6.7.1.

Analysis>P-Delta Analysis Control>

Lanciare l’analisi 

8.5. Visione dei grafici riassuntivi per le colonne

Results>Column Shortening Graph for C.S.

Name: C1
Coordinate Info> X: 0  ;  Y: 0

 > 

Check C1_Creep_Sub ~ C1_Shrnk_Up
Stages> #CS12
Y-Axis Option> Story

Up to Casting: accorciamento delle colonne immediatamente precedente la gettata del piano
corrente
Sub to Casting: accorciamento delle colonne susseguente la gettata del piano corrente
Totale: Somma dell’accorciamento delle colonne prima e dopo la gettata.
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Salvare il grafico di ritiro per le colonne in un file di testo
Click tasto destro > Save Graph as Text


