
MIDAS/Gen V.720 EnhancementsMIDAS/Gen V.720 Enhancements

Major  EnhancementsMajor  Enhancements

Modellazione ed Analisi

Risultati

• Car ichi da vento secondo Eurocode 1 (2005)
• Car ichi sismici statici equivalenti secondo Eurocode 8 (2004)
• Compor tamento di mater iale ���� Muratura����  Strumas (Prof. Pande, Swansea)
• Nuova funzione per l���� input di car ichi eccentr ici su travi
• Molte nuove funzioni sulle analisi di Pushover

• Combinazione di Mxx Mxy Myy in ���� Plate Force/Moment Result����
• Miglioramento in output delle analisi di Pushover
• Miglioramenti nella presentazione delle Tabelle
• Display delle forze di taglio ai Piani per  ogni Modo di vibrare



Major  EnhancementsMajor  Enhancements

Ver ifiche e Progetto di sezioni

• Stato L imite di Servizio secondo Eurocode 2 &  3
• Assegnazione delle armature per  membratura
• Non considerazione di Compressioni/Tensioni estremamente r idotte in Nonlinear  Memb
ers
• Novità nei Risultati del Design calcestruzzo (Armature, Area and Rappor ti mostrati sepa
ratamente)
• Novità nel Design dell����acciaio
• Novità nella trattazione degli effetti or togonali nei Casi di Car ico Sismici

Altro

• Miglioramenti nelle funzioni di Display
• Opzioni Grafiche aggiunte in Preferences Menu
• Salvataggio di tutti i Graphic Design Results in formato di file
grafico



Modeling &  Analysis Par t
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Modeling &  Analysis Par t

(1) Wind Load Calculation Standard Eurocode 1 (2005) has been added 

� MIDAS/Gen Online Manual V.720
    - Refer to Loads > Lateral Loads > Wind Load

Loads > Lateral Loads > Wind Load
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Auto-calculation of 
Gust effect factor

Auto-calculation of 
Gust effect factor

Gust effect factor and 
auto-calculated 

parameters

Gust effect factor and 
auto-calculated 

parameters

Wind loads auto-calculated 
as per Eurocode (2005)

Wind loads auto-calculated 
as per Eurocode (2005)



Modeling &  Analysis Par t

(2) Static Seismic Load Calculation Standard Eurocode 8 (2004) has been added 

� MIDAS/Gen Online Manual V.720
    - Refer to Loads > Lateral Loads > Static Seismic Load

Loads > Lateral Loads > Static Seismic Load

Reference
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Modeling &  Analysis Par t

(3) Masonry Material Models have been added 

� Applicable only to 8-node Solid elements

� MIDAS/Gen Online Manual V.720
    - Refer to Model > Property > Plastic Material

Model > Property > Plastic Material

Comment &  Reference

Related post-processor

� Results > Stresses > Solid Stress

Brick MaterialBrick Material Bed Joint MaterialBed Joint Material Head Joint MaterialHead Joint Material Geometry of Masonry PanelGeometry of Masonry Panel

Yield status 
at each step
Yield status 
at each step



Modeling &  Analysis Par t

(4) Addition of a function to enable the input of Eccentric Beam Loads 

� Eccentric beam loads can be inputted in ECS or GCS.

�

 Eccentric beam load is applied as a concentrated load and
a moment due to eccentricity internally by the prog
ram.

� MIDAS/Gen Online Manual V.720

    - Refer to Loads > Element Beam Load & Line Beam Lo
ad

Load >  Element Beam Loads

Input of Eccentric Beam LoadsInput of Eccentric Beam Loads

Example of input of 
eccentric beam load
Example of input of 
eccentric beam load

Applied eccentric loadsApplied eccentric loads

Comments &  Reference

Load >  Line Beam Loads



Modeling &  Analysis Par t

(5) Enhancements of Pushover Analysis function

� User can define the Shear Spring Location
   (the option to consider the additional moment occurring a
t the end of the element due to shear deformation).

� MIDAS/Gen Online Manual V.720
    - Refer to Model > Boundary > General Link Property

Model > Boundary > General Link Property
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� 	 �� * � � 
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�–� � 
� � ��� �  � 
  � � �$

Applicable to Spring Type onlyApplicable to Spring Type only

Enter elastic property of SpringEnter elastic property of Spring

Comment &  Reference

Enter Shear Spring LocationEnter Shear Spring Location



Modeling &  Analysis Par t

Model > Boundary > General Link Property

! ' � " � � � 
 #� � � � � � 
$� �� � � � � � ��
 � � � � � � � � � �   
�� � � �
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Model > Property > Inelastic Hinge Property

� MIDAS/Gen Online Manual V.720
    - Refer to Model > Property > Inelastic Hinge Property
    - Refer to Model > Boundary > General Link Property

Comment &  Reference
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Applicable to inelastic hingesApplicable to inelastic hinges

Applicable only when 
User Input, Spring and None 

types are selected

Applicable only when 
User Input, Spring and None 

types are selected

All Hysteresis Models built-in 
MIDAS/Gen can be used

All Hysteresis Models built-in 
MIDAS/Gen can be used
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� ' � � � � � � � � � � � �� � 
 � � " 
� � ��� � , �� ( � �

i. Disequilibrium force in a member has been resolved

ii. Improvement in convergence of p
ushover analysis using wall element
s

M f- M q-

EI HingeF F F= + EI HingeF F F= +Flexibility of a m
ember

01/6L from both ends
Plastic length of

a member

At both ends of a me
mber

At both ends of a me
mber

Inelastic hinge

Flexural member

FEMAMulti-linear

Pushover Analysis

a. FEMA Type: Enable the user to define the initial stiffness o
f flexural member to be used in inelastic analysis

b. Multi-linear Type: Distributed hinge type for inelastic ti
me history analysis has been added

Define initial 
stiffness of 

flexural member

Define initial 
stiffness of 

flexural member



Modeling &  Analysis Par t

- ' � � � � � � � � � � � �� � �� � � 
 � #� � ( � � � � � " � 
 � 
� � � � � � � . � 
�� � �
��$� 
 � � " � � � 
 #� � � � � � 
$� ��

Design > Pushover Analysis > Pushover Analysis Control

i. Convergence Criteria, Force Norm and Energy Norm have been added

Force Norm and Energy Norm addedForce Norm and Energy Norm added

ii. Residual disequilibrium force after the convergence for each increment i
s determined has been resolved

iii. Revision of hysteresis routine – Unloading routine added

iiii. Enhancements of algorithm to improve other convergence problem

� MIDAS/Gen Online Manual V.720
    - Refer to Design > Pushover Analysis > Pushover
Analysis Control

Reference
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�  MIDAS/Gen V.720 Online Manual

    - Refer to Results > Forces > Plate Force

Reference

(1) Display of Moment Combination in Plate Force/Moment Result

Results > Forces > Plate Forces / Moments
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(2) Enhancements of Pushover Analysis Result

Results > Deformations > Deformed Shape

Related Functions
� Design > Pushover Analysis > Hinge Status Table

�  MIDAS/Gen V.720 Online Manual
      Refer to Results > Deformations > Deformed Shape

Reference

Display Multi-linear 
type hinge

Display Multi-linear 
type hinge

Display FEMA 
type hinge

Display FEMA 
type hinge

� ' � - ��  
� $� , �� ( � � � �� �� � � 
 � � ) � � � � � 
� 	 �� * � � 
� � � � ��



(3) Enhancements of Story Result Tables

� MIDAS/Gen Online Manual V.720

    - Refer to Results > Result Tables > Story  Shear Force Ra
tio

� Story Shear Force due to RS loads is calculated by combin
ing the story shear forces of each mode using the mo
dal combination method.

Related Functions

� Model > Buildong >  Control Data
   - Story Shear Force Ratio Check On

Reference
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�  If Story Drift is negative (-), the stiffness of the correspond
ing story is displayed with "-

T
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Related Functions

� Story Result Tables that display NG in the Remark colu
mn

    - Story Drift
    - Story Shear Force Coefficient
    - Torsional Irregularity Check
    - Stiffness Irregularity Check
    - Weight Irregularity Check
    - Capacity Irregularity Check
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Already existedStory Mode Shape

Already existedTorsional I rregularity Check

Already existedStability Coefficient

Already existedStory Axial Force Sum

Already existedOverturning Moment

Already existedStiffness I rregularity Check

Newly addedStory Eccentricity

Newly addedStory Shear Forces (Response Spectrum Analysis)

Already existedStory Displacement

Already existedStory Drift

Newly addedStory Shear Force Ratio

Already existedTorsional Amplification Factor

 RemarkApplication of Module function

Already existedCapacity I rregularity Check



�  MIDAS/Gen Online Manual V.720

    - Results > Result Tables > Story Drift
    - Results > Result Tables
      > Story Drift (Time History Analysis)
    - Results > Result Tables
      > Story Shear (Response Spectrum Analysis)
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Related Functions

� Loads > Response Spectrum Analysis Data >
Response Spectrum Load Case

� Analysis > Eigenvalue Analysis Control

�  Results >  Result Tables > Story >
    Story Shear Force Ratio,
    Story Shear (Response Spectrum Analysis)

(4) Display Story Shear Force for each Mode

Results > Result Text Output (* . MSR, * . GA1)
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(1) Serviceability Checks as per Eurocode 2 & 3

Results > Combinations
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�  MIDAS/Gen V.720 Online Manual

    - Refer to [Procedure for Serviceability Check as per Euro
code 2] in Design > Concrete Code Checking > Beam Che
cking

    - Refer to [Procedure for Serviceability Check as per Euro
code 3] in Design > Steel Code Check

Related Function

� Design > General Design Parameters >
   Serviceability Load Combination Type
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�  Graphic Report
    - Crack Control
    - Deflection Control

� Detail Report
    - Stress (Strength Results)
    - Crack (Serviceability Results)

� MIDAS/Gen V.720 Online Manual

    - Refer to [Procedure for Serviceabilit
y Check as per Eurocode 2] in Design
> Concrete Code Checking > Beam C
hecking

    - Refer to [Procedure for Serviceabilit
y Check as per Eurocode 3] in Design
> Steel Code Check
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Design > Steel Code Check

� Graphic Report
    - Deflection Checking Results

� Detail Report
    - Check Deflection

� MIDAS/Gen V.720 Online Manual

    - Refer to [Procedure for Serviceability Chec
k as per Eurocode 2] in Design > Concrete Co
de Checking > Beam Checking

    - Refer to [Procedure for Serviceability Chec
k as per Eurocode 3] in Design > Steel Code
Check

Comments &  References

�

� 


�

�

��

�

� 


�

�

��

�

� 


�

�

��

�

� 


�

�

��

`

` `

`

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

a

a a

a

�

� 


�

�

��

�

� 


�

�

��

�

� 


�

�

��

�

� 


�

�

��

`

` `

`

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

2

�

	 �
� �

�

�


 �

W 7
� �

X�

� �

Z

� �

�

�

�

�

a

a a

a

2

�

�  

�

��

2

�

�  

�

��

2

�

�  

�

��

2

�

�  

�

��

`

` `

`

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

a

a a

a

� � �

�

�

�

�

� � �

�

�

�

�� � �

�

�

�

�

� � �

�

�

�

�

2

�

�  

�

��

2

�

�  

�

��

2

�

�  

�

��

2

�

�  

�

��

`

` `

`

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

W 7
� �

X

2

�

	 �
� �

�

�


 �

a

a a

a

� � �

�

�

�

�

� � �

�

�

�

�� � �

�

�

�

�

� � �

�

�

�

�



(2) Assign Rebars by Members

Design > Concrete Design Parameters > Design Criteria for Rebar by Members

� MIDAS/Gen V.720 Online Manual

  - Design > Concrete Design Parameters
    > Design Criteria for Rebar by Members
  - Design > Concrete Design Parameters
    > Concrete Design Tables >  Design Criteria for Rebar by

Members
� While 

b

Design Criteria for Rebars

c

 enables the user to assig
n rebars by sections,  

b

Design Criteria for Rebar by Member
s

c

 enables the user to assign rebars by members. 

b

Design Cr
iteria for Rebar by Members

c

 precedes 

b

Design Criteria for
Rebars

c

 when both are assigned.

Design > Concrete Design Parameters 
> Concrete Design Tables >  Design Criteria for Rebar by Members
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(3) Disregard of Extremely Small Compression/Tension in Nonlinear Members 

Design >  Steel Code Check

Related Functions

� Model > Elements > Create Element
   Tension Only/Hook/Cable, Compression Only/Gab

� Load >
   Create Load Cases Using Load Combinations

� Analysis > Main Control Data

Design > Concrete Code Design > RC, Column, Wall, Brace Design

Design > SRC Code Check > Column Checking
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(4) Enhancements of Concrete Design Result (Rebar, Area and Ratio separately displayed)

� MIDAS/Gen V.720 Online Manual

    - Refer to Design > Concrete Design Result

Reference

Design > Concrete Design Result
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(5) Enhancements of Steel Design
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Old Version: Detail report used to display the calculations corresponding to the location of member and load combination,
 which produced the most critical combined stress.

New Version: Detail report displays the calculations corresponding to the location of member, which produces the more
 critical one of the most unfavorable combined stress and the most unfavorable shear stress.
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(6) Enhancements of Orthogonal Effect  in Seismic Load Cases

Related Function

� Results > Combinations
   Set Load Cases for  Or thogonal Group
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- While generating static seismic load combinations with Orthogonal Effect considered, only one load combination was generated. For example, only
one of [E(X), E(Y)], [E(Y),E(Z)] and [E(Z),E(X)] could be generated. (This was identically applied to Response Spectrum Loads.)

- [E(X), E(Y)], [E(Y),E(Z)] and [E(Z),E(X)] can be all generated. (This is identically applied to Response Spectrum Loads.)

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

�� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 ��� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 � �

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

��

�

��

�

��

�

��

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

t

�

�

� 
 � �

�


 �

�

� 
 �

� �

� �

�

�


 � �


�

� � �

�

�� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 ��� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 � �

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

��

�

��

�

��

�

��

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

�� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 ��� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 � �

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

��

�

��

�

��

�

��

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

u

 

�



1 �


 �

�

� 
 �

� �

� �

�

�


 � � � ��

�

�

�� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 ��� � � � �

�

�

� 	

 �

�� � � � �

�

�

� 	

 � �

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

�

�

�

�

�

� � �

�

� �

�

�

�


 �

�

��

�

��

�

��

�

��

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

� � �  
 � � � �  � �

�
�

�

�

�


 �

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

]

� � �  � �

�

�

8 �

�

�

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

+

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.

�

e

� S

-

Z

1

.



� � � �� � ��� � � �� � ��

� � � � � � � � � � � � � � �� � 
 � � - ��  
� $� � � � � ��
 �

� � � � ) � �  � �� � �7  ��
 � � � � � � � � �� � " � � � � � � � � � � �& � � �

�%� � � � #� � � 

� ) � �  � �� � - � � �( � � . � � � 
�� � � � � � � ( � �  � �� � � �
� � � 
 � � � �



(1) Enhancements of Display function

� MIDAS/Gen V.712 Online Manual

    - Refer to View > Display Option

View > Display Option

Related Functions

� Results > Deformations > Deformed Shape
    - Inelastic Time History Analysis Result
    - Pushover Analysis Result
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�  MIDAS/Gen V.712 Online Manual

    - Refer to View > Display

View > Display

Related Functions

� Model > Property > Sections
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(2) Graphics Option added in Preferences Menu

� MIDAS/Gen V.720 Online Manual

    - Refer to Tools > Preference

Reference

Tools > Preference
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(3) Save all Graphic Design Results as a graphic file format

Design > Design Result Dialog & Code Check Result Dialog

Revision of V720 Revision of V720 

Old Version: Save the graphic design result of a single member or property

New Version: Save the graphic design results of a lot of members or properties


